我想在 post-auth 部分向远程系统日志发送消息。简单的字符串
"'%{User-Name}', '%{reply:Packet-Type}', '%{Calling-Station-Id}'"
FreeRADIUS 3 怎么做?
或者..
如何按设施或优先级拆分日志?
我想在 post-auth 部分向远程系统日志发送消息。简单的字符串
"'%{User-Name}', '%{reply:Packet-Type}', '%{Calling-Station-Id}'"
FreeRADIUS 3 怎么做?
或者..
如何按设施或优先级拆分日志?
我想在 proxy_pass 服务器上使用 API 制作 CORS 站点。但
location / {
if ($request_method = 'OPTIONS') {
add_header 'Access-Control-Allow-Origin' '*';
add_header 'Access-Control-Allow-Credentials' 'true';
add_header 'Access-Control-Allow-Methods' 'GET, POST, OPTIONS';
add_header 'Access-Control-Allow-Headers' 'DNT,X-CustomHeader,Keep-Alive,User-Agent,X-Requested-With,If-Modified-Since,Cache-Control,Content-Type';
add_header 'Access-Control-Max-Age' 86400;
add_header 'Content-Type' 'text/plain charset=UTF-8';
add_header 'Content-Length' 0;
return 204; break;
}
if ($request_method = 'POST') {
add_header 'Access-Control-Allow-Origin' '*';
add_header 'Access-Control-Allow-Credentials' 'true';
add_header 'Access-Control-Allow-Methods' 'GET, POST, OPTIONS';
add_header 'Access-Control-Allow-Headers' 'DNT,X-CustomHeader,Keep-Alive,User-Agent,X-Requested-With,If-Modified-Since,Cache-Control,Content-Type';
}
if ($request_method = 'GET') {
add_header 'Access-Control-Allow-Origin' '*';
add_header 'Access-Control-Allow-Credentials' 'true';
add_header 'Access-Control-Allow-Methods' 'GET, POST, OPTIONS';
add_header 'Access-Control-Allow-Headers' 'DNT,X-CustomHeader,Keep-Alive,User-Agent,X-Requested-With,If-Modified-Since,Cache-Control,Content-Type';
}
location /api/ {
proxy_pass http://api:8080/;
proxy_set_header Host $host:$server_port;
proxy_set_header X-Real-IP $remote_addr;
}
}
从上游返回 405。如果没有 proxy_pass,此代码段将按预期工作。
如何破解并返回204?
我在和接口上有 2 个静态地址(a.b.c.72/24
和a.b.c.128/24
) 。ISP 有一个网关 。我只能在 上使用,只能在 上使用。gateway1
gateway2
a.b.c.1
a.b.c.72
gateway1
a.b.c.128
gateway2
如何让 abc128 工作?我想通过第二个接口路由一些本地机器。我知道一些通过 mikrotik 中不同网关进行路由的方法。在linux中我可以指定dev参数来路由。
我添加了路由表和规则,但它仍然通过 gateway2 路由。
/ip dhcp-client print
Flags: X - disabled, I - invalid
# INTERFACE USE ADD-DEFAULT-ROUTE STATUS ADDRESS
0 gateway1 yes no bound X.Y.164.72/24
1 gateway2 yes no bound X.Y.164.128/24
/ip route
add distance=51 gateway=X.Y.164.1 pref-src=X.Y.164.128 routing-mark=gate2
add distance=1 dst-address=X.Y.164.0/24 gateway=gateway2 pref-src=X.Y.164.128 routing-mark=gate2
add distance=52 gateway=X.Y.164.1 pref-src=X.Y.164.72 routing-mark=gate1
add distance=1 dst-address=X.Y.164.0/24 gateway=gateway1 pref-src=X.Y.164.72 routing-mark=gate1
add distance=52 gateway=X.Y.164.1
add distance=10 dst-address=10.0.0.0/8 gateway=center
在选定的行上,我需要具有等效的 iproute,ip route add default via 109.60.164.1 dev gateway2 table gate2
但它通过 gateway1 接口路由
NAT
/ip firewall nat
add action=masquerade chain=srcnat out-interface=gateway1
add action=masquerade chain=srcnat out-interface=gateway2
Mangle 现在很干净。它标记了来自选定客户端的连接和路由。这不是问题,并且适用于不同的网关。
我有一个 IP 地址池,但反向 DNS 不起作用。如果在 namserver 上查找但在 Internet 上不起作用,则它可以工作。
我要求注册商将此池委托给ns1.example.com
. 我添加net IN NS ns1.example.com
了域 dns-hosting。我添加了 PTR 以ipXXX.net.example.com
绑定在ns1.example.com
.
# host a.b.c.17
Host 17.26.18.37.in-addr.arpa. not found: 3(NXDOMAIN)
# dig +short 17.b.c.a.in-addr.arpa.
# dig +short b.c.a.in-addr.arpa.
# dig +short b.c.in-addr.arpa.
dig +short
是空的,没有缩写它指向 RIPE。
我在 RouterBoard 上有 IP 池、2 个提供商和 BGP。第一个提供者是默认的。二是备份。如果第一个提供者倒下 - 传出连接在第二个工作。但传入仍然路由到损坏的提供商。
如何使服务器可用率更高?
我有一个 Linux 主机和几个路由器板。我创建了一个 GRE 隧道,但 Linux 不回答keepalive包。然后路由器将 gre 连接标记为不可达,所以我无法从路由器子网发送到 Linux 主机。如果 linux 将某些东西发送到隧道(ping 等) - RouterOS 将连接标记为可达。第二个和下一个包裹很好地路由,直到一分钟空闲(没有流量)。
linux中的隧道以这种方式制作:
remote=x.x.x.x
dev=gre21
network=10.21.0.0/16
ip tunnel add ${dev} mode gre remote ${remote} ttl 255
ip addr add 172.16.1.1/24 peer 172.16.1.21 dev ${dev}
ip link set ${dev} up
ip route add ${network} dev ${dev}
并且 ip l
:
14: gre21: <POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1476 qdisc noqueue state UNKNOWN
link/gre 0.0.0.0 peer 109.60.170.15
如何设置状态“运行”?
如何让隧道保持活力?在cron中ping?